Tube Radio Forum - The friendliest radio forum on the net!
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Hallicrafters S-38C

Go down

Hallicrafters S-38C Empty Hallicrafters S-38C

Post by Motorola man on Thu Feb 26, 2015 9:56 pm

I'm working on the fore mentioned radio & have hit a snag. I've replaced all of the usual suspects & now have audio but no reception on any band. I haven't had much of a chance to do any advanced troubleshooting yet. Does anyone know of any common issues that this model radio may have?

Dave
Motorola man
Motorola man
Member
Member

Number of posts : 370
Age : 45
Registration date : 2010-02-06

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Motorola man on Thu Feb 26, 2015 10:04 pm

Hallicrafters S-38C 680D0227-B1FD-48A5-ACC8-9D062D550A01
The back cover was crumbling, so I made a new one out of lexan.

Hallicrafters S-38C AE88111F-9242-4AB7-86DC-1C6E4FF7AADE
Under the chassis.
Motorola man
Motorola man
Member
Member

Number of posts : 370
Age : 45
Registration date : 2010-02-06

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by willy3486 on Thu Feb 26, 2015 11:08 pm

The one I use I rebuilt about 1991 and it didn't give me any trouble. I picked up two of the other 38 radios I need to redo. Anyway there is a good resource at

s38 guy

He has a lot of good info and I think a link to your issue you are having.

willy3486
Member
Member

Number of posts : 1384
Registration date : 2011-07-02

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Wildcat445 on Fri Feb 27, 2015 12:09 am

What are you using for an antenna? Have you cleaned the band switch? Good luck.

WC

Wildcat445
Member
Member

Number of posts : 4893
Registration date : 2011-09-19

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Bill Cahill on Fri Feb 27, 2015 10:46 am

Several things come to mind. Those mica caps., the local oscillator may not be working, tried testing tubes, cleaning tube sockets, and, tube pins, checked resistors, etc.???

_________________
Please also join us here; www.videokarma.org/index.php
Bill Cahill
Bill Cahill
Admin
Admin

Number of posts : 4419
Age : 69
Registration date : 2008-03-12

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by scottb on Fri Feb 27, 2015 5:21 pm

I had problems with the standby/ receive switch on mine

scottb
Member
Member

Number of posts : 115
Registration date : 2008-03-12

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Bill Cahill on Fri Feb 27, 2015 7:10 pm

Hmm. Forgot they had one. Yep; That can cause it............

_________________
Please also join us here; www.videokarma.org/index.php
Bill Cahill
Bill Cahill
Admin
Admin

Number of posts : 4419
Age : 69
Registration date : 2008-03-12

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Motorola man on Fri Feb 27, 2015 10:48 pm

I've checked the switches, swapped all but one tube, plus a few other checks here & there. I'm going to dive a little deeper into it tomorrow. Thanks for the recommendations. I'll updat with what I find.
Motorola man
Motorola man
Member
Member

Number of posts : 370
Age : 45
Registration date : 2010-02-06

Back to top Go down

Hallicrafters S-38C Empty Re: Hallicrafters S-38C

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum