Tube Radio Forum - The friendliest radio forum on the net!
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Zenith X338-complete recap and still got AC noise.

Go down

Zenith X338-complete recap and still got AC noise. Empty Zenith X338-complete recap and still got AC noise.

Post by dorpmuller on Tue Jan 27, 2009 1:04 pm

Hi guys,

Title says it all... every cap replaced and I'm still getting AC noise thru audio. Haven't done the selenium yet but that's next. (X338 is the same as the C845)

This isn't the only radio this has happened with... it's almost like the last couple recap jobs went for nothing.

Where do I go from here? Of course ARF is no good again... posted there but with it down all the time I gave up.

Thanks,

Rich
dorpmuller
dorpmuller
Member
Member

Number of posts : 31
Registration date : 2009-01-15

Back to top Go down

Zenith X338-complete recap and still got AC noise. Empty Re: Zenith X338-complete recap and still got AC noise.

Post by Resistance is Futile on Thu Jan 29, 2009 12:11 am

easy way to check b+ is use VOM in DC mode, if meter doesn't move, replace rectifier. If it moves in either direction then its, probably OK. If it wiggles back and forth then yes you have bad selenium.

You may also have a bad ground somewhere, or need to reroute wires around volume control. These are simple solutions, if this doesn't work, more serious testing is in store.
Resistance is Futile
Resistance is Futile
Member
Member

Number of posts : 912
Registration date : 2008-03-12

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum