crosley phono

View previous topic View next topic Go down

crosley phono

Post by denver on Mon Nov 01, 2010 1:38 pm

I have recapped the whole set . Has radio and phono. Radio playing great . Phono just makes humming sound .
Like a bad filter cap makes but i put ALL, new caps in. The table spins changer works. It just hums through speaker.
Any info Thanks Denver. model 03CQ.
avatar
denver
Member
Member

Number of posts : 402
Age : 57
Registration date : 2010-01-18

Back to top Go down

Re: crosley phono

Post by Tony V on Mon Nov 01, 2010 8:40 pm

I would check the cartridge because if its open, it will cause the humming sound that you describe. Also check the tone arm wiring for any shorts or loose wires all the way to where it connects to the chassis. Disconnecting the tone arm plug at the chassis will tell you if its a cartridge or wiring problem. If disconnecting it still produces hum then theres a wiring problem in the radio itself.
-Tony
avatar
Tony V
Moderator
Moderator

Number of posts : 620
Age : 48
Registration date : 2008-09-13

Back to top Go down

Re: crosley phono

Post by denver on Tue Nov 02, 2010 6:38 pm

Thank you very much. Iwill do and let you know.
Thanks again Denver Smile
avatar
denver
Member
Member

Number of posts : 402
Age : 57
Registration date : 2010-01-18

Back to top Go down

Re: crosley phono

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum