Zenith Chassis 5K505 audio problems

Go down

Zenith Chassis 5K505 audio problems

Post by Blaine on Tue Oct 12, 2010 7:38 pm

Hello all.
Just finished the recap of this set . Did the resistance checks , continuity test in coils and all tested well . Replaced 1 bad tube . Plugged set in let it run for an hour or so beautiful sound . Installed unit back in set and soldered loop back to set and now i get an oscillation I believe. I still here the station but the audio sounds muffled. When I disconnect loop from set works great. When I touch the antenna lead with my finger I get the same muffled sound.Loop tests Ok . When I take long wire antenna and clip to antenna lead same thing. However when I merely wrap wire around lead reception improves.I have not ordered a schematic yet to do some voltage checks and other tests. The tube layout is 12BE6-12BA6-35W4-12AV6-5DC5.
Thanks
avatar
Blaine
Member
Member

Number of posts : 20
Age : 52
Registration date : 2008-12-06

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Blaine on Tue Oct 12, 2010 7:54 pm

OOPS. That's model 5K05
avatar
Blaine
Member
Member

Number of posts : 20
Age : 52
Registration date : 2008-12-06

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by sprman on Tue Oct 12, 2010 7:59 pm

Humm sounds like maybe to much gain ...You can look at tube data shets to get max voltages for them ,then check set voltages..Check the tubes 12be 12 ba,swap them out with others if you have them.Just my 2 cents worth..Sprman

sprman
Member
Member

Number of posts : 365
Age : 63
Registration date : 2008-03-27

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by denver on Tue Oct 12, 2010 10:08 pm

Did you replace all caps. Might be a leaky cap in the oscillation circuit.
avatar
denver
Member
Member

Number of posts : 402
Age : 58
Registration date : 2010-01-18

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Bill Cahill on Tue Oct 12, 2010 10:55 pm

Sounds like mica caps in oscilator have gone leaky, also, sometimes there is a paper cap in antenna circuit. If so, replace.
Did you replace ALL the paper caps?
Bill Cahill

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4582
Age : 67
Registration date : 2008-03-12

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Resistance is Futile on Wed Oct 13, 2010 3:48 pm

The one tube you mentioned 5DC5 seems out of place. I tried doing a search and came up with only a slight mention of a diode?

You already have a power diode 35w4 in the string.
even adding the 5CD5 in the string doesn't add up to 110 volts for filaments.
Your 34 volts short for a series string.
I think maybe someone did some tubes substitutions? Or do you have a tube location chart on the radio?
I looked in Universal Schematic Locator and found nothing for that model of Zenith.
avatar
Resistance is Futile
Member
Member

Number of posts : 976
Age : 74
Registration date : 2008-03-12

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Blaine on Wed Oct 13, 2010 6:41 pm

Thanks for the replies. First the tube is a 50c5 .One finger typing ya know. I also changed all the paper capacitors.I have not tested the Mica caps yet .There is a square component same color tan as the mica caps. I am thinking this is a cap as well It has 2 or 3 leads from it with some numbers on it. Have to do some un soldering of a cap to see closer. I have ordered a schematic for the set today.
will keep the post posted .
Thanks
avatar
Blaine
Member
Member

Number of posts : 20
Age : 52
Registration date : 2008-12-06

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Blaine on Wed Oct 13, 2010 10:22 pm

Checked all the mica caps and they tested good. Tested in circuit with a Paco 25 cap tester.The one component not sure of is numbered IC5-A3 it has seven leads from it . Lead numbers I think there is a series of numbers above the leads 123456Y
lead 1 to pin 1 of 12AV6
lead 2 to center tap of volume control
lead 3 to if can
lead 4 to pin 5 12AV6
lead 5 to pin 2 50C5
lead6 to pin 8 12AV6
lead 7 to pin 7 50C5
avatar
Blaine
Member
Member

Number of posts : 20
Age : 52
Registration date : 2008-12-06

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Resistance is Futile on Thu Oct 14, 2010 3:14 pm

I think your describing a Couplate. They had a combination of caps and resistors designed as a network to replace or eliminating additional wiring and or bulky parts. may have to find a circuit that has those. There are some listed on the web with diagrams. I don't remember where. Try googling. confused (Click Here--> #)
avatar
Resistance is Futile
Member
Member

Number of posts : 976
Age : 74
Registration date : 2008-03-12

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Blaine on Thu Oct 14, 2010 8:13 pm

Thanks for that info on couplates. Something new to me .Will do some more research.
avatar
Blaine
Member
Member

Number of posts : 20
Age : 52
Registration date : 2008-12-06

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by denver on Thu Oct 14, 2010 8:45 pm

Couplates are used in a lot of tube radios ect. In the audio section. I found thishttp://www.amwindow.org/tech/htm/couplate.htm I will loof for more info.
avatar
denver
Member
Member

Number of posts : 402
Age : 58
Registration date : 2010-01-18

Back to top Go down

Re: Zenith Chassis 5K505 audio problems

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum