farnsworth BT600 new volume problem

Go down

farnsworth BT600 new volume problem

Post by knoxjr on Wed Jan 31, 2018 10:19 am

Hi Guys I have a Farnsworth BT600 that I recapped replaced a shorted tube and replaced on off volume control. I thought I had it working great. The problem is that weak long distance stations can be heard for about 10-15 seconds when the radio is first turned on and the sound gets lower and lower till it cant be heard. I can turn the radio off and back on and hear the weak station for about 10-15 seconds at that time only strong local stations on the am band can be heard. I have a long wire antenna. Thanks in advance for the help.

knoxjr
New Member
New Member

Number of posts : 4
Registration date : 2018-01-31

Back to top Go down

Re: farnsworth BT600 new volume problem

Post by Bill Cahill on Thu Feb 01, 2018 3:57 pm

Welcome to TRF. Sou nds like either tuner plates may be shorting out, or, look for off value resistors, or, leaky mica capacitors.
Hope this helps....

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4559
Age : 66
Registration date : 2008-03-12

Back to top Go down

plates broke off tuning cap

Post by knoxjr on Fri Feb 02, 2018 10:00 am

Thanks Bill Cahill for the reply your suggestion of tuner plates shorted out reminded me that when I first started working on this radio that one section of the three gang tuning cap plates hit together and two or three plates broke off. I wasn't worried about it because the radio appeared to work ok. Could that cause this problem ? Thanks again for the help

knoxjr
New Member
New Member

Number of posts : 4
Registration date : 2018-01-31

Back to top Go down

Re: farnsworth BT600 new volume problem

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum