Sencore LC53 Question

View previous topic View next topic Go down

Sencore LC53 Question

Post by WC1C on Wed Jul 09, 2014 1:24 pm

Hi,

I have a Sencore LC53 LCR meter. When the unit is turned on the digital meter displays 0093. I can not zero the meter. The unit can read caps but how accurate I do not know. Can anyone help me trouble shoot the darn thing? Thanks

WC1C
New Member
New Member

Number of posts : 2
Registration date : 2014-07-09

Back to top Go down

Re: Sencore LC53 Question

Post by Bill Cahill on Wed Jul 09, 2014 2:09 pm

Your test leads may be adding some capacity. Try unplugging them.
If you are trying to test caps in radios best to just replace original paper caps.

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4538
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Sencore LC53 Question

Post by willy3486 on Wed Jul 09, 2014 3:16 pm

I think Bill is on to something with the capacitance of the leads. I think my Sencore cap checker is the same model. It is rock steady so to speak. I have never had a moment of trouble with it. There is a manual of it at http://bama.edebris.com/manuals/sencore/lc53/
The manual has info on calibrating it.
I use my to check new caps when I put them in. It and the sencore isolation transformer are my two best pieces I have had. I have had them over twenty years and have never had a moments trouble with them. I can't say the same on my sencore scope.

willy3486
Member
Member

Number of posts : 1400
Registration date : 2011-07-02

Back to top Go down

Re: Sencore LC53 Question

Post by WC1C on Wed Jul 09, 2014 4:00 pm

I get the same reading whether the leads are attached or not. I even shorted the leads with the same results. I have a copy of the manual and all it says is adjust the zero with the knob.

WC1C
New Member
New Member

Number of posts : 2
Registration date : 2014-07-09

Back to top Go down

Re: Sencore LC53 Question

Post by Bill Cahill on Wed Jul 09, 2014 4:06 pm

What does it do when you do that with leads out??

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4538
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Sencore LC53 Question

Post by willy3486 on Wed Jul 09, 2014 5:06 pm

Sounds like it may need to be serviced. Sencore use to service them , I am not sure if they still do. I am wondering if a cap had a charge and was tested, it could have done something to it. I would work from the test lead connection back and check items.
There is also a circuit diagram at http://www.download-service-manuals.com/en/manual.php?file=Sencore-5918.pdf

Maybe that will help.

willy3486
Member
Member

Number of posts : 1400
Registration date : 2011-07-02

Back to top Go down

Re: Sencore LC53 Question

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum