What I have been up to

Go down

What I have been up to Empty What I have been up to

Post by willy3486 on Fri Oct 25, 2013 11:52 pm

Well its not radio related, not exactly. I had hoped that when I started my shop reorginization I would be done in a month or so. Well that was a few years ago and new projects push it back. Anyway back in the summer my wife and I discussed getting a new to us truck. Well we couldn't find one. The mother in law gave the father in laws truck to my wifes brother. He was letting it go to waste so I mentioned to my wife we should buy it from him. She said yes of course. So we bought it from him, how I wind up taking care of the MIL and she gives the BIL who doesn't help her the truck I will never know. But oh well thats the way it goes. I pulled it out of the barn and have been busy. It is a one owner 1970 Chevy C10 he bought new. He took excellent care of it and it ran like a sewing machine so to speak when he was driving it. It has low miles for its age of just about 120 k. So far I have replaced the plugs,plug wires,distributor cap, all cooling hoses,all rubber gas lines,gas pump,changed the oil,new dash ,pulled the gas tank to clean and recoat the inside. This is what I remember doing. So this is my project keeping me from radios. Next week I have a guy lined up to rebuild the carb and put new points in. He does a good job and I don't have luck with points. By the time we get it to running,new paint job,tires,seat cover and a few odds and ends that need to be done we will more than likely have less in it than a worn out 8 year old truck we looked at on the dealership lot. If no one minds here is a link of the post I put with pictures on the chevy site. If I need to I can delete it.

Chevy truck

willy3486
Member
Member

Number of posts : 1380
Registration date : 2011-07-02

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by Bill Cahill on Sat Oct 26, 2013 12:04 am

Sounds nice. Any pics??

_________________
Please also join us here; www.videokarma.org/index.php
Bill Cahill
Bill Cahill
Admin
Admin

Number of posts : 4392
Age : 68
Registration date : 2008-03-12

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by willy3486 on Sat Oct 26, 2013 12:25 am

I have pictures on the link ,I have about ten or so there. I also have more info.
I even have pics of a original chevy 8 track from then I plan to put in as well.

Click here to see pics

willy3486
Member
Member

Number of posts : 1380
Registration date : 2011-07-02

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by Wildcat445 on Sat Oct 26, 2013 9:36 am

Nice truck, Willy. What engine is there? Maybe a 307? Or a two barrel 350? Either engine will run longer than you will even after suffering major neglect. I would suggest that you install an Ignitor in the distributor in place of points. Three reasons for that, really. Number one is serviceability. Few mechanics (technicians) know how to work on points nowadays. And the distributor on those old Chevys is mounted on the rear of the engine and you have to dive across the radiator and air cleaner to work on them. Second is dependability. There are simply no good points made anymore. The last Chevy V-8 with points was made in 1974. R&D money is long gone. Another alternative is to install a later model distributor with factory electronic ignition. Third reason is you will be a happier Chevy owner being done with points. That engine will start better, run better, run cleaner and have more power with electronic ignition. Points will start to deteriorate from the minute they are installed. Electronic ignition is literally forever. There are parts that can and do fail, but the failure rate on electronic ignition is miniscule compared to breaker point ignition. An Ignitor fits right in the stock distributor where the points were. Costs about $100 and takes ten minutes to install. Good luck with your Chevy. I have a 1973 with a 454 and it has been converted to a later factory distributor with HEI.

Regards

WC

Wildcat445
Member
Member

Number of posts : 4893
Registration date : 2011-09-19

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by willy3486 on Sat Oct 26, 2013 10:26 am

307 it is. As far as points I have a guy coming over to install them that is good. As far as ignitor that could be a real possibility in its future. Right now I just want to get it running. Its been siting so I would like to get it to run so I can use it and and just run it so it doesn't go down again like it has.

willy3486
Member
Member

Number of posts : 1380
Registration date : 2011-07-02

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by Dr. Radio on Sat Oct 26, 2013 9:40 pm

Cool project.

That truck forum is a good place, but if you ever have any questions they can't answer, hit me up. As you may or may not know, I'm restoring a '70 Chevelle my dad ordered new...and it has a 307.

I know a lot of th ins and outs and quirks (like the 1970 T.C.S. system) etc.
Dr. Radio
Dr. Radio
Member
Member

Number of posts : 899
Age : 39
Registration date : 2012-09-17

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by Guest on Sat Oct 26, 2013 10:07 pm

You didn't mention brakes and wheel cylinders, you need to do this as well. Also check all brake lines. The hardware store where I worked at as a kid had a brand new 1970 Chevy C20 pickup. I like Fords and have 3 trucks and 2 Broncos all from the 1970's. I also have a 1966 Galaxie 500 2DR HT. Old vehicles are a lot of fun. Enjoy your truck! Very Happy 

Guest
Guest


Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by willy3486 on Sat Oct 26, 2013 10:18 pm

Mezlaw good advice, the brakes are done. I wanted to do that first as I am use to doing them . New brake shoes,cylinders and some lines as well. So that hopefully is done.

I belonged to a Ford truck forum and quit because of the folks there. They had a mindset I didn't want to be a part of, a lot of hate and anger there. I did find another truck site for my Ford after it was running. But it was running and I lost interest because I was getting into radios by then. I joined that chevy site when we got the truck. So far no complaints from me on the site. I can post a question and get a answer in no time. I am having a issue with the shifter and they have walked me through it to the point I think I can get it. As far as the truck goes I hope by this weekend to have it running. If all goes well I have a guy coming out to rebuild the carb. I tried rebuilding my carb on the ford twice before giving up and getting a rebuilt one.

This guy seems to be excellent at engines. He had some bad luck with his health and was trying to get back to being able to work full time. So I got him to rebuild my tractors carb and he got it running great. So far it seems to be going good. I have the brakes and fuel system for the most part redone.

There is one weird issue see if you have an idea. When you turn the truck over the oil pressure sender goes all the way over to high. This is without it running. It is a pressure type one not electric. On that site I have been told it could be anything  from normal when starting and it will go back to normal after it is running to that its the oil pump and needs to be replaced. I hope its the one of it being normal as the truck was running perfect and no issues when parked.

willy3486
Member
Member

Number of posts : 1380
Registration date : 2011-07-02

Back to top Go down

What I have been up to Empty Re: What I have been up to

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum