Recap complete......

View previous topic View next topic Go down

Recap complete......

Post by maddoghuey on Tue Mar 26, 2013 9:31 pm

Hello all,

I am new here and joined due to a recent project of mine that has spurred an interest in old tube stereos/radios. I recently acquired a Motorola SK76WA that I just finished re-capping the four filter caps and it sounds great except one channel has some static. I was going to replace the preamp tubes, 3 12AX7s and see how that goes before getting to the power amp tubes. Does anyone have any advice? Is this a good idea? Also, it has a Vibrosonic contraption that I disconnnected b/c it sounded horrible but it uses 'compression lamps'. can these be found anywhere?

Any help/advise is much appreciated!

maddoghuey
New Member
New Member

Number of posts : 2
Registration date : 2013-03-26

Back to top Go down

Re: Recap complete......

Post by Dr. Radio on Tue Mar 26, 2013 10:32 pm

Hello,

Did you only replace the filter capacitors? If this set has any wax/paper capacitors they need to be replaced as well for reliable/safe operation before just swapping tubes.

The "Vibrasonic" is Motorola's version of reverberation I believe. Back in the '60s, many people who could not afford true stereo systems for their cars had "reverbs" for that SUNDAY SUNDAY SUNDAY ECHOOOOOOOO sound! It's a love it or hate it taste.

Static can also be caused by poor solder connections/dirty band switches, volume and tone controls etc. that need cleaning.

avatar
Dr. Radio
Member
Member

Number of posts : 937
Age : 37
Registration date : 2012-09-17

Back to top Go down

Re: Recap complete......

Post by Guest on Tue Mar 26, 2013 10:34 pm

I still have one or two of those auto reverberators! They controlled the speaker in the back deck.

Guest
Guest


Back to top Go down

Re: Recap complete......

Post by 75X11 on Tue Mar 26, 2013 10:43 pm

I had a grade school teacher with a '66 Mustang with a reverb. Every time he went across a bump, that thing sounded like 12 noon in a tower clock factory!
avatar
75X11
Member
Member

Number of posts : 4900
Age : 61
Registration date : 2013-03-10

Back to top Go down

Re: Recap complete......

Post by Guest on Tue Mar 26, 2013 10:53 pm

75X11 wrote:I had a grade school teacher with a '66 Mustang with a reverb. Every time he went across a bump, that thing sounded like 12 noon in a tower clock factory!

LOL.....I forgot about that, it was due to the long spring inside! lol!

Guest
Guest


Back to top Go down

Re: Recap complete......

Post by maddoghuey on Tue Mar 26, 2013 10:57 pm

Yeah, just the filter caps. I believe there may be one more, all the rest I think are ceramic. The vibro thing I thnik is basically a spring reverb box like you would find in guitar amps. Thanks for the advice, I'll check for any more paper caps before retubing.

maddoghuey
New Member
New Member

Number of posts : 2
Registration date : 2013-03-26

Back to top Go down

Re: Recap complete......

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum