Town Crier tube version

View previous topic View next topic Go down

Town Crier tube version

Post by ractonymontana on Fri Jul 20, 2012 8:17 pm

I bought this radio at a flea market because it worked. I brought it home and decided to lubricate the rollers so the tuning knob would move. It also had static in the volume knob so I used electrical cleaner for this. After words I waited 15 mins for it to dry. I plugged it back in and it did not work anymore. It still does not work. What can I check to help it. I am not an expert or even a novice. Please help!

ractonymontana
New Member
New Member

Number of posts : 4
Registration date : 2012-07-20

Back to top Go down

Re: Town Crier tube version

Post by Bill Cahill on Fri Jul 20, 2012 8:35 pm

Hi, and, welcome to the forums.....
What on the tuner did you oil? If only the bearings, and, cernter part, fine. If more than that, you've thrown the frequency way off.
Electrical cleanner? I hope it doesn't say it gets rid of carbon..... If it does, you will need to replace your volume control.
Also, for further stability, the radio should be re capped, and, have power supply electrolytics replaced.
Bill Cahill

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4523
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Town Crier tube version

Post by ractonymontana on Sat Jul 21, 2012 1:50 pm

Thanks Bill. When I turn it on a couple of the tubes glow but there is no sound no static no anything. What could I sell this radio for as is? I know nothing about tubes. I oiled just the rollers. I used electric cleaner on the plates the move cause they were filled with dust.

ractonymontana
New Member
New Member

Number of posts : 4
Registration date : 2012-07-20

Back to top Go down

Re: Town Crier tube version

Post by Bill Cahill on Sat Jul 21, 2012 4:46 pm

Ah!
Finally, a break!!
Get yourself some electronic tuner contact cleanner at Radio Shack.
Use if fairly liberally on all tuner plates, and, let it thoroughly dry.
My guess is in a day, or, so, the radio will start playing again.
When you try to use any cleanner on these plates, it throws the tunning way off.
Maybe use contact cleanner. Not degreaser.
A brush would have been plenty.
Tuners are very sensitive.
I don't believe the radio is beyond hope.
Clean it the right way, I'd reccommend tuner cleanner because it tends not to cause tunning drift, and, let it dry.
It should come back.
Bill Cahill

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4523
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Town Crier tube version

Post by ractonymontana on Sat Jul 21, 2012 5:42 pm

Ok so this would cause it to not even make any static or any noise. I can try your sugggestion. Can I post picture of radio.

ractonymontana
New Member
New Member

Number of posts : 4
Registration date : 2012-07-20

Back to top Go down

Re: Town Crier tube version

Post by Bill Cahill on Sat Jul 21, 2012 6:31 pm

If you have a program like Photo bucket, yes.
Post pictures right in your threads.
Easy to explain. One sectio of the tuner is in the oscilator circuit.
When you sprayed it it threw the oscilator so far off that the oscilator quit working.
It may take a few days to come totally back.
Bill Cahill

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4523
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Town Crier tube version

Post by ractonymontana on Sat Jul 21, 2012 6:38 pm

LOL it has been 2 months. OOPS

ractonymontana
New Member
New Member

Number of posts : 4
Registration date : 2012-07-20

Back to top Go down

Re: Town Crier tube version

Post by Bill Cahill on Sat Jul 21, 2012 6:41 pm

Huh???? Two months since what????
Bill Cahill

_________________
Please also join us here;  http://videokarma.org/index.php
avatar
Bill Cahill
Admin
Admin

Number of posts : 4523
Age : 66
Registration date : 2008-03-12

Back to top Go down

Re: Town Crier tube version

Post by GaryRabbitt on Sun Jul 29, 2012 5:48 am

HI,
I think that you should have the set checked out before you do anything else to it. Some cleaners contain a lube and will not dry out. I took a can of the Radio Shack stuff back because it left too much oil. It is good for a lube, but I wouldn't clean contacts with it.
There is no need to spray cleaner into the plates of a tuning cap. A soft brush and compresed air is best.
You can lube the ball bearings, and contact piece (brass) on the unit.
If you got cleaner inside of a trimmer capacitor's mica, it may never dry out. Hope you didin't sporay it into an IF can.
So, you get absolutely nothing from the speaker. Listen carefully. There should still be a slight hiss of dead air.

I don't understand about lubing the 'rollers'. Ball bearings in the tuning cap?

It's always hard to diagnise a problem over the net, especially if you know nothing about the workings of a radio.

As far as a couple of tubes being lit, they should all light up, or none at all. I believe it is a series string of filaments. So, like the old Xmas lights, if one is burned out, it supplies no voltage to the other tubes.

Oull out, then reinstall each of the tubes. One might not be making contact.

Those are neat radios, I don't think they are valued too high though, and do have a simple circuit. Yes, you can sell i as is, but knowing it worked once, it should not take much to find the problem and repair it. Something simple I am sure.
Keep it around until you get more experience, or sell it to someone that does know how to repair them.

avatar
GaryRabbitt
Member
Member

Number of posts : 96
Registration date : 2008-07-04

Back to top Go down

Re: Town Crier tube version

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum