Zenith R721...please help!!

View previous topic View next topic Go down

Zenith R721...please help!!

Post by topwurst on Thu Feb 24, 2011 12:19 am

I'm an amateur, but love old radios. My Zenith R721 has great tone and reception. However, the volume gets very loud and low by itself, and often. Is this a tube problem??

topwurst
New Member
New Member

Number of posts : 2
Registration date : 2011-02-24

Back to top Go down

Re: Zenith R721...please help!!

Post by Resistance is Futile on Fri Feb 25, 2011 12:27 am

The first thing to try is remove the tubes and reinsert, as you may have a tube socket that may need cleaning. As you remove and replace it in its socket it may wipe off any corrosion present. It could be as the radio warms up, it could have either a tube or a component that may be breaking down or a bad solder connection that expands and contracts under heat. Try removing the chassis, and using an insulated piece of plastic (like a pencil shape) and lightly tap different parts to see if when you tap it it changes volume. If so you have found the part that is either defective or needs re-soldering.
avatar
Resistance is Futile
Member
Member

Number of posts : 976
Age : 73
Registration date : 2008-03-12

Back to top Go down

Re: Zenith R721...please help!!

Post by topwurst on Fri Feb 25, 2011 12:41 pm

Thanks, I'll try that, and post my results...please stay tuned!!

topwurst
New Member
New Member

Number of posts : 2
Registration date : 2011-02-24

Back to top Go down

Re: Zenith R721...please help!!

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum